Student error pages
Incident Report for Touch-type Read and Spell
Resolved
This incident has been resolved.
Posted Jun 12, 2018 - 16:57 BST
Update
We are continuing to investigate this issue.
Posted Jun 12, 2018 - 16:42 BST
Investigating
We are aware that some student accounts are receiving error messages. We are investigating this issue.
Posted Jun 12, 2018 - 16:26 BST
This incident affected: API and Management Portal.