Module access
Incident Report for Touch-type Read and Spell
Resolved
This incident has been resolved.
Posted Dec 03, 2022 - 11:32 GMT
Investigating
We are aware that some users are not able to access TTRS modules. We are investigating this issue.
Posted Dec 03, 2022 - 11:10 GMT