Slow performance
Incident Report for Touch-type Read and Spell
Resolved
This incident has been resolved.
Posted 8 months ago. Feb 08, 2019 - 12:25 GMT
Identified
Some users may be experiencing slow performance when navigating the site. This is being investigated.
Posted 8 months ago. Feb 08, 2019 - 10:31 GMT
This incident affected: API.