Downtime
Incident Report for Touch-type Read and Spell
Resolved
This incident has been resolved.
Posted Oct 21, 2019 - 08:59 BST
Identified
Expected downtime until 9am BST
Posted Oct 21, 2019 - 08:39 BST
This incident affected: API and Management Portal.